]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Remove further no more necessary stuff from debian/rules
[pkg/mmv.git] / debian / rules
index 79f430eb8124f48bd3e885fa251cbc6025f914ac..e2f6fba0d75c167ecc86ecf8e7a04820aacad2d8 100755 (executable)
@@ -1,7 +1,5 @@
 #! /usr/bin/make -f
 
-INSTALL_PROGRAM=install
-CC = gcc
 LDFLAGS =
 CFLAGS = -g -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
 
@@ -13,9 +11,7 @@ else
 endif
 
 ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
-    INSTALL_PROGRAM += -s
     LDFLAGS += -s
-    STRIP = true
 endif
 
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
@@ -23,16 +19,6 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
     MAKEFLAGS += -j$(NUMJOBS)
 endif
 
-
-# The package
-p = mmv
-# The version
-v = $(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
-# The architecture
-a = $(shell dpkg --print-architecture)
-
-dir = `pwd`
-
 build:
 # Builds the binary package.
        dh_testdir
@@ -43,9 +29,7 @@ clean:
 # Undoes the effect of `make -f debian/rules build'.
        dh_testdir
        dh_auto_clean
-       -rm -f debian/files* debian/substvars* debian/*~ core */core *~
-       rm -rf debian/tmp
-       -rm build
+       dh_clean build debian/substvars
 
 binary: binary-arch binary-indep
 
@@ -54,44 +38,17 @@ binary-indep:
 
 binary-arch: build
        dh_testdir
-       test -f build || $(MAKE) -f debian/rules build
 # Makes a binary package.
-       /bin/rm -rf debian/tmp
-       test -f stamp-build || $(MAKE) -f debian/rules build
-       install -d -g root -m 755 -o root debian/tmp
-       chmod g-s debian/tmp
-       install -d -g root -m 755 -o root debian/tmp/DEBIAN
-       install -d -g root -m 755 -o root debian/tmp/usr/bin
-       install -d -g root -m 755 -o root debian/tmp/usr/share/man/man1
-       install -d -g root -m 755 -o root debian/tmp/usr/share/lintian/overrides
-       $(INSTALL_PROGRAM) -g root -o root -m 755 mmv debian/tmp/usr/bin
-       test "$(STRIP)" != true || strip \
-               --remove-section=.comment --remove-section=.note \
-               debian/tmp/usr/bin/mmv
-       install -g root -o root -m 644 mmv.1 debian/tmp/usr/share/man/man1
-       gzip -9f debian/tmp/usr/share/man/man1/mmv.1
-       (cd debian/tmp/usr/bin;\
-        ln -s mmv mcp; \
-        ln -s mmv mad; \
-        ln -s mmv mln;)
-       (cd debian/tmp/usr/share/man/man1;\
-        ln -s mmv.1.gz mcp.1.gz; \
-        ln -s mmv.1.gz mad.1.gz; \
-        ln -s mmv.1.gz mln.1.gz;)
-       install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
-       install -g root -m 644 -o root READ.ME \
-               debian/tmp/usr/share/doc/$(p)
-       install -g root -m 644 -o root debian/changelog \
-               debian/tmp/usr/share/doc/$(p)/changelog.Debian
-       gzip -f9 debian/tmp/usr/share/doc/$(p)/*
-       install -g root -m 644 -o root debian/copyright \
-         debian/tmp/usr/share/doc/$(p)
-       install -g root -m 644 -o root debian/lintian-overrides \
-         debian/tmp/usr/share/lintian/overrides/mmv
-       chmod -R g-sw debian/tmp/usr/share/doc/$(p)
-       chown -R root.root debian/tmp/usr/share/doc/$(p)
-       dpkg-shlibdeps debian/tmp/usr/bin/mmv
-       dpkg-gencontrol -isp
-       cd debian/tmp && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
-                xargs -r0 md5sum > DEBIAN/md5sums
-       dpkg --build debian/tmp && dpkg-name -o -s .. debian/tmp.deb
+       dh_installdirs
+       dh_auto_install
+       dh_strip
+       dh_link
+       dh_installdocs
+       dh_installchangelogs
+       dh_compress
+       dh_lintian
+       dh_fixperms
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb