]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Remove further no more necessary stuff from debian/rules
[pkg/mmv.git] / debian / rules
index 6736aa86c5b4e073ae5b192f8717ee9adf7bc74c..e2f6fba0d75c167ecc86ecf8e7a04820aacad2d8 100755 (executable)
@@ -1,6 +1,5 @@
 #! /usr/bin/make -f
 
-CC = gcc
 LDFLAGS =
 CFLAGS = -g -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
 
@@ -20,16 +19,6 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
     MAKEFLAGS += -j$(NUMJOBS)
 endif
 
-
-# The package
-p = mmv
-# The version
-v = $(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
-# The architecture
-a = $(shell dpkg --print-architecture)
-
-dir = `pwd`
-
 build:
 # Builds the binary package.
        dh_testdir
@@ -49,23 +38,11 @@ binary-indep:
 
 binary-arch: build
        dh_testdir
-       test -f build || $(MAKE) -f debian/rules build
 # Makes a binary package.
-       /bin/rm -rf debian/tmp
-       test -f stamp-build || $(MAKE) -f debian/rules build
        dh_installdirs
-       dh_install
+       dh_auto_install
        dh_strip
-       dh_installman
-       (cd debian/tmp/usr/bin;\
-        ln -s mmv mcp; \
-        ln -s mmv mad; \
-        ln -s mmv mln;)
-       (cd debian/tmp/usr/share/man/man1;\
-        ln -s mmv.1.gz mcp.1.gz; \
-        ln -s mmv.1.gz mad.1.gz; \
-        ln -s mmv.1.gz mln.1.gz;)
-       install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
+       dh_link
        dh_installdocs
        dh_installchangelogs
        dh_compress