]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Use dh_auto_install, installs to debian/mmv instead of debian/tmp
[pkg/mmv.git] / debian / rules
index a92ecf6ae79d2a9eaa42e280eaa472f41395f966..7bfcfaf98001947059dcfc8898f16ec357fa01fa 100755 (executable)
@@ -51,23 +51,19 @@ binary-arch: build
        dh_testdir
        test -f build || $(MAKE) -f debian/rules build
 # Makes a binary package.
-       /bin/rm -rf debian/tmp
        test -f stamp-build || $(MAKE) -f debian/rules build
-       install -d -g root -m 755 -o root debian/tmp
-       chmod g-s debian/tmp
-       install -d -g root -m 755 -o root debian/tmp/DEBIAN
-       dh_install
+       dh_installdirs
+       dh_auto_install
        dh_strip
-       dh_installman
-       (cd debian/tmp/usr/bin;\
+       (cd debian/mmv/usr/bin;\
         ln -s mmv mcp; \
         ln -s mmv mad; \
         ln -s mmv mln;)
-       (cd debian/tmp/usr/share/man/man1;\
+       (cd debian/mmv/usr/share/man/man1;\
         ln -s mmv.1.gz mcp.1.gz; \
         ln -s mmv.1.gz mad.1.gz; \
         ln -s mmv.1.gz mln.1.gz;)
-       install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
+       install -d -g root -m 755 -o root debian/mmv/usr/share/doc/$(p)
        dh_installdocs
        dh_installchangelogs
        dh_compress