]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Finalize
[pkg/mmv.git] / debian / rules
index 6736aa86c5b4e073ae5b192f8717ee9adf7bc74c..63237708b8bdef46c7c252b6bb48d01d86115753 100755 (executable)
@@ -1,77 +1,10 @@
 #! /usr/bin/make -f
 
-CC = gcc
-LDFLAGS =
-CFLAGS = -g -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
 
+%:
+       dh $@
 
-ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
-    CFLAGS += -O0
-else
-    CFLAGS += -O2
-endif
-
-ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
-    LDFLAGS += -s
-endif
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    MAKEFLAGS += -j$(NUMJOBS)
-endif
-
-
-# The package
-p = mmv
-# The version
-v = $(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
-# The architecture
-a = $(shell dpkg --print-architecture)
-
-dir = `pwd`
-
-build:
-# Builds the binary package.
-       dh_testdir
-       $(MAKE) CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
-       touch build
-
-clean:
-# Undoes the effect of `make -f debian/rules build'.
-       dh_testdir
-       dh_auto_clean
-       dh_clean build debian/substvars
-
-binary: binary-arch binary-indep
-
-binary-indep:
-       dh_testdir
-
-binary-arch: build
-       dh_testdir
-       test -f build || $(MAKE) -f debian/rules build
-# Makes a binary package.
-       /bin/rm -rf debian/tmp
-       test -f stamp-build || $(MAKE) -f debian/rules build
-       dh_installdirs
-       dh_install
-       dh_strip
-       dh_installman
-       (cd debian/tmp/usr/bin;\
-        ln -s mmv mcp; \
-        ln -s mmv mad; \
-        ln -s mmv mln;)
-       (cd debian/tmp/usr/share/man/man1;\
-        ln -s mmv.1.gz mcp.1.gz; \
-        ln -s mmv.1.gz mad.1.gz; \
-        ln -s mmv.1.gz mln.1.gz;)
-       install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
-       dh_installdocs
-       dh_installchangelogs
-       dh_compress
-       dh_lintian
-       dh_fixperms
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+override_dh_auto_build:
+       dh_auto_build -- LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS) $(shell getconf LFS_CFLAGS) -DIS_SYSV -DHAS_DIRENT -DHAS_RENAME"