]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Imported Debian patch 1.01b-14
[pkg/mmv.git] / debian / rules
index c6b78b5bd947541366c616759328efe09290ce57..82666b8056750f63a4995f59d81971ad92931d82 100755 (executable)
@@ -1,7 +1,20 @@
 #! /usr/bin/make -f
 
+INSTALL_PROGRAM=install
 CC = gcc
-LDFLAGS = -s
+LDFLAGS =
+CFLAGS = -O2 -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+CFLAGS += -g
+endif
+
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+INSTALL_PROGRAM += -s
+LDFLAGS += -s
+endif
+
 
 # The package
 p = mmv
@@ -15,15 +28,16 @@ dir = `pwd`
 build:
 # Builds the binary package.
        $(checkdir)
-       make CC="$(CC)" LDFLAGS="$(LDFLAGS)"
+       make CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
        touch build
 
 clean:
 # Undoes the effect of `make -f debian/rules build'.
        $(checkdir)
-       make clean
-       /bin/rm -f debian/files* debian/substvars*
-       /bin/rm -rf debian/tmp build
+       -make clean
+       -rm -f debian/files* debian/substvars* debian/*~ core */core *~
+       rm -rf debian/tmp
+       -rm build
 
 binary: binary-arch binary-indep
 
@@ -40,30 +54,31 @@ binary-arch: build
        chmod g-s debian/tmp
        install -d -g root -m 755 -o root debian/tmp/DEBIAN
        install -d -g root -m 755 -o root debian/tmp/usr/bin
-       install -d -g root -m 755 -o root debian/tmp/usr/man/man1
-       install -g root -o root -m 755 -s mmv debian/tmp/usr/bin
-       install -g root -o root -m 644 mmv.1 debian/tmp/usr/man/man1
-       gzip -9f debian/tmp/usr/man/man1/mmv.1
+       install -d -g root -m 755 -o root debian/tmp/usr/share/man/man1
+       $(INSTALL_PROGRAM) -g root -o root -m 755 mmv debian/tmp/usr/bin
+       install -g root -o root -m 644 mmv.1 debian/tmp/usr/share/man/man1
+       gzip -9f debian/tmp/usr/share/man/man1/mmv.1
        (cd debian/tmp/usr/bin;\
         ln -s mmv mcp; \
         ln -s mmv mad; \
         ln -s mmv mln;)
-       (cd debian/tmp/usr/man/man1;\
+       (cd debian/tmp/usr/share/man/man1;\
         ln -s mmv.1.gz mcp.1.gz; \
         ln -s mmv.1.gz mad.1.gz; \
         ln -s mmv.1.gz mln.1.gz;)
-       install -d -g root -m 755 -o root debian/tmp/usr/doc/$(p)
+       install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
        install -g root -m 644 -o root READ.ME \
-               debian/tmp/usr/doc/$(p)
+               debian/tmp/usr/share/doc/$(p)
        install -g root -m 644 -o root debian/changelog \
-               debian/tmp/usr/doc/$(p)/changelog.Debian
-       gzip -f9 debian/tmp/usr/doc/$(p)/*
+               debian/tmp/usr/share/doc/$(p)/changelog.Debian
+       gzip -f9 debian/tmp/usr/share/doc/$(p)/*
        install -g root -m 644 -o root debian/copyright \
-         debian/tmp/usr/doc/$(p)
-       chmod -R g-sw debian/tmp/usr/doc/$(p)
-       chown -R root.root debian/tmp/usr/doc/$(p)
+         debian/tmp/usr/share/doc/$(p)
+       chmod -R g-sw debian/tmp/usr/share/doc/$(p)
+       chown -R root.root debian/tmp/usr/share/doc/$(p)
        dpkg-shlibdeps debian/tmp/usr/bin/mmv
-       dpkg-gencontrol
+       dpkg-gencontrol -isp
+       dh_md5sums
        dpkg --build debian/tmp && dpkg-name -o -s .. debian/tmp.deb
 
 define checkdir