]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Use dh_installdirs
[pkg/mmv.git] / debian / rules
index 56b1f6a8b1d4502ddf4e6901e4ba5c6b941868b4..6736aa86c5b4e073ae5b192f8717ee9adf7bc74c 100755 (executable)
@@ -53,15 +53,10 @@ binary-arch: build
 # Makes a binary package.
        /bin/rm -rf debian/tmp
        test -f stamp-build || $(MAKE) -f debian/rules build
-       install -d -g root -m 755 -o root debian/tmp
-       chmod g-s debian/tmp
-       install -d -g root -m 755 -o root debian/tmp/DEBIAN
-       install -d -g root -m 755 -o root debian/tmp/usr/bin
-       install -d -g root -m 755 -o root debian/tmp/usr/share/man/man1
-       install -g root -o root -m 755 mmv debian/tmp/usr/bin
+       dh_installdirs
+       dh_install
        dh_strip
-       install -g root -o root -m 644 mmv.1 debian/tmp/usr/share/man/man1
-       gzip -9f debian/tmp/usr/share/man/man1/mmv.1
+       dh_installman
        (cd debian/tmp/usr/bin;\
         ln -s mmv mcp; \
         ln -s mmv mad; \
@@ -73,10 +68,10 @@ binary-arch: build
        install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
        dh_installdocs
        dh_installchangelogs
+       dh_compress
        dh_lintian
-       chmod -R g-sw debian/tmp/usr/share/doc/$(p)
-       chown -R root.root debian/tmp/usr/share/doc/$(p)
-       dpkg-shlibdeps debian/tmp/usr/bin/mmv
+       dh_fixperms
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb