]> git.deb.at Git - pkg/netris.git/blobdiff - debian/rules
Comment out the homepage URL
[pkg/netris.git] / debian / rules
index 2622a1db33c2faa65376ea06eae4871259279e94..3ff179415d52e0f8c9b4ac7f2400aa17f0aaa4c1 100755 (executable)
@@ -1,62 +1,18 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+#DH_VERBOSE = 1
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+%:
+       dh $@
 
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       # Add here commands to compile the package.
-       ./Configure -O2
-       make
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       # Add here commands to clean up after the build process.
-       $(MAKE) clean
 
+override_dh_clean:
+       -rm -rf config.h .depend
        dh_clean
+       -rm -f Makefile
 
-# Build architecture-independent files here.
-binary-indep: build
-# We have nothing to do by default.
+override_dh_auto_configure:
+       ./Configure -g
 
-# Build architecture-dependent files here.
-binary-arch: build
-       dh_testversion 2.0.40
-       dh_testdir
-       dh_testroot
-       dh_clean -k
+override_dh_installdirs:
        dh_installdirs
-
-       # Add here commands to install the files into debian/tmp
-       install -s netris debian/tmp/usr/games
-       install -s sr debian/tmp/usr/games/netris-sample-robot
-
-       dh_installdocs FAQ robot_desc
-       dh_installexamples sr.c
-       dh_installmenu
-       dh_installmanpages
-       dh_undocumented netris.1 netris-sample-robot.1
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+       cp sr debian/netris/usr/games/netris-sample-robot