]> git.deb.at Git - pkg/abook.git/blobdiff - debian/rules
add Denis Briand as co-maintainer
[pkg/abook.git] / debian / rules
index 3cb12039ccceaa7a4962ac2752ad73a153a54a20..440446042e8e859a7d674b1ecc9868de568876d7 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for abook
-# copyright 2003-2009 by Gerfried Fuchs <rhonda@debian.at>
-# Licenced under BSD style
+# copyright 2003-2012 by Gerfried Fuchs <rhonda@debian.org>
+# Licenced under WTFPLv2
 
 PKG = abook
 TMP = $(CURDIR)/debian/$(PKG)
@@ -9,7 +9,7 @@ TMP = $(CURDIR)/debian/$(PKG)
 QUILT_STAMPFN = patch-stamp
 include /usr/share/quilt/quilt.make
 
-CFLAGS = -g -Wall
+CFLAGS = -g -Wall -std=gnu89
 INSTALL = install
 INSTALL_FILE    = $(INSTALL) -p    -oroot -groot -m644
 INSTALL_PROGRAM = $(INSTALL) -p    -oroot -groot -m755
@@ -43,7 +43,9 @@ clean: unpatch
        [ ! -f Makefile ] || $(MAKE) distclean
 
 
-build: build-stamp
+build: build-arch
+build-arch: build-stamp
+build-indep:
 build-stamp: patch-stamp
        $(checkdir)
        cp /usr/share/misc/config.guess /usr/share/misc/config.sub .