]> git.deb.at Git - pkg/abook.git/blobdiff - debian/rules
Add debhelper token into maintainers scripts.
[pkg/abook.git] / debian / rules
index 2b9ba31988b8aca70825f1e6d9290ffa15d5d894..10900f0edca51c7ecf5aebc34ba77808e5df5c82 100755 (executable)
@@ -6,4 +6,14 @@ export DEB_CFLAGS_MAINT_APPEND  = -g -Wall -pedantic -std=gnu89
 export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
 %:
-       dh $@ --with autotools_dev
+       dh $@ --with autoreconf
+
+#Place debugging symbols into abook-dbg package
+override_dh_strip:
+       dh_strip --dbg-package=abook-dbg
+
+override_dh_auto_install:
+       dh_auto_install --destdir=debian/abook
+
+override_dh_installdocs:
+       dh_installdocs --link-doc=abook