]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Add recommended targets build-arch/build-indep to debian/rules
[pkg/t-prot.git] / debian / rules
index 947d2a1c7b50c66a6749a061e5ab2db070d72fd1..f55ee4ace36389d4cc5aee320f25df0c5967c245 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 # debian/rules for t-prot package
-# Copyright 2002-2009 by Gerfried Fuchs <rhonda@debian.at>
+# Copyright 2002-2012 by Gerfried Fuchs <rhonda@debian.org>
 # Licenced under WTFPLv2
 
 PKG = t-prot
@@ -16,16 +16,18 @@ INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
 clean:
        $(checkdir)
        $(checkroot)
-       -rm -rf $(TMP) debian/files build-stamp
+       -rm -rf $(TMP) debian/files debian/stamp-*
 
-
-build-stamp: build
-build:
+build: build-arch build-indep
+build-arch: debian/stamp-build
+build-indep: debian/stamp-build
+debian/stamp-build:
        # uhm, build for a binary-indep package?  Don't try to be funny ;)
-       touch build-stamp
+       touch debian/stamp-build
 
 
-install: build
+install: debian/stamp-install
+debian/stamp-install: build
        $(checkdir)
        $(checkroot)
        -rm -rf $(TMP)
@@ -58,7 +60,7 @@ install: build
                man/man1/t-prot.1
 
 
-binary-indep: build install
+binary-indep: install
        $(checkdir)
        $(checkroot)
        $(INSTALL_DIR) $(TMP)/DEBIAN