]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Convert debian/rules to dh style
[pkg/t-prot.git] / debian / rules
index ed79cf847f29bd62dacabf159234278bd26d7282..f4257007c89beca7a0ae3646bc46b4f79b816802 100755 (executable)
@@ -1,99 +1,8 @@
 #!/usr/bin/make -f
-# debian/rules for t-prot package
-# Copyright 2002-2012 by Rhonda D'Vine <rhonda@debian.org>
-# Licenced under WTFPLv2
+#DH_VERBOSE = 1
 
-PKG = t-prot
-TMP = $(CURDIR)/debian/$(PKG)
-BUILD_DATE = $(shell dpkg-parsechangelog --show-field Date)
 
-INSTALL = install
-INSTALL_FILE    = $(INSTALL) -p    -oroot -groot -m644
-INSTALL_PROGRAM = $(INSTALL) -p    -oroot -groot -m755
-INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
-INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
-
-
-clean:
-       $(checkdir)
-       $(checkroot)
-       -rm -rf $(TMP) debian/files debian/stamp-*
-       $(MAKE) -f /usr/share/quilt/quilt.make unpatch
-
-build: build-arch build-indep
-build-arch: debian/stamp-build
-build-indep: debian/stamp-build
-debian/stamp-build:
-       # only thing to do is apply the patches ...
-       $(MAKE) -f /usr/share/quilt/quilt.make patch
-       touch debian/stamp-build
-
-
-install: debian/stamp-install
-debian/stamp-install: build
-       $(checkdir)
-       $(checkroot)
-       -rm -rf $(TMP)
-       $(INSTALL_DIR) $(TMP)
-       cd $(TMP) && $(INSTALL_DIR) etc/t-prot/footers etc/t-prot/ads \
-               usr/bin usr/share/man/man1 usr/share/slrn/macros \
-               usr/share/doc/$(PKG)/examples
-       #       usr/share/doc/$(PKG)/contrib
-       $(INSTALL_SCRIPT) t-prot   $(TMP)/usr/bin
-       $(INSTALL_FILE)   t-prot.1 $(TMP)/usr/share/man/man1
-       $(INSTALL_FILE) debian/Muttrc     $(TMP)/etc/t-prot
-       $(INSTALL_FILE) debian/footers/*  $(TMP)/etc/t-prot/footers
-       $(INSTALL_FILE) contrib/t-prot.sl $(TMP)/usr/share/slrn/macros
-
-       $(INSTALL_FILE) TODO README $(TMP)/usr/share/doc/$(PKG)
-       $(INSTALL_FILE) contrib/filter_innd.pl contrib/README.examples \
-               $(TMP)/usr/share/doc/$(PKG)/examples
-       $(INSTALL_FILE) ChangeLog \
-               $(TMP)/usr/share/doc/$(PKG)/changelog
-       cd $(TMP)/usr/share && gzip -n9 doc/$(PKG)/changelog \
-               man/man1/t-prot.1
-
-
-binary-indep: install
-       $(checkdir)
-       $(checkroot)
-       $(INSTALL_DIR) $(TMP)/DEBIAN
-       $(INSTALL_FILE) debian/copyright debian/README.Debian \
-               $(TMP)/usr/share/doc/$(PKG)
-       $(INSTALL_FILE) debian/changelog \
-               $(TMP)/usr/share/doc/$(PKG)/changelog.Debian
-       cd $(TMP)/usr/share/doc/$(PKG) && gzip -n9 \
-               changelog.Debian
-       $(INSTALL_SCRIPT) debian/postinst debian/postrm debian/config \
-               $(TMP)/DEBIAN
-       po2debconf debian/templates > $(TMP)/DEBIAN/templates
-       $(INSTALL_FILE) debian/conffiles \
-               $(TMP)/DEBIAN
-       dpkg-gencontrol -ldebian/changelog -isp -p$(PKG) -P$(TMP)
-       cd $(TMP) && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
-               xargs -r0 md5sum > DEBIAN/md5sums
-       # Make build reproducible:
-       # Hardcode permissions for files created by output redirection
-       chmod 644 $(TMP)/DEBIAN/md5sums $(TMP)/DEBIAN/templates
-       # Set timestamp of all files to timestamp in debian/changelog entry
-       find $(TMP) -depth -newermt '$(BUILD_DATE)' -print0 | \
-               xargs -0r touch --no-dereference --date='$(BUILD_DATE)'
-       dpkg --build $(TMP) ..
-
-
-binary-arch:
-       # We have nothing to do here.
-
-
-binary: binary-indep
-
-
-define checkdir
-       test -f debian/rules
-endef
-
-define checkroot
-       test root = "`whoami`"
-endef
-
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@
+       # not sure about override for po2debconf needed
+       # po2debconf debian/templates > $(TMP)/DEBIAN/templates