]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Hardcode file permissions for files generated by output redirection
[pkg/t-prot.git] / debian / rules
index 3104ee7cbf347106377ae6d7f445ed75433c6d83..4f411be445df673a3b3fd66fa460917ebb2b4314 100755 (executable)
@@ -72,6 +72,10 @@ binary-indep: install
        dpkg-gencontrol -ldebian/changelog -isp -p$(PKG) -P$(TMP)
        cd $(TMP) && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
                xargs -r0 md5sum > DEBIAN/md5sums
+       # Make build reproducible:
+       # Hardcode permissions for files created by output redirection
+       chmod 644 $(TMP)/DEBIAN/md5sums $(TMP)/DEBIAN/templates
+       # Set timestamp of all files to timestamp in debian/changelog entry
        find $(TMP) -depth -newermt '$(BUILD_DATE)' -print0 | \
                xargs -0r touch --no-dereference --date='$(BUILD_DATE)'
        dpkg --build $(TMP) ..