]> git.deb.at Git - pkg/mmv.git/commitdiff
Imported Debian patch 1.01b-12.2 debian/1.01b-12.2
authorAri Pollak <ari@debian.org>
Sat, 13 Aug 2005 05:01:13 +0000 (01:01 -0400)
committerAxel Beckert <abe@deuxchevaux.org>
Fri, 7 Sep 2012 10:59:54 +0000 (12:59 +0200)
debian/changelog
mmv.c

index dce778f60ef6a63eaf565b82b6ca01f7e0667c10..fe17bd34c9812342c416b70f9ffd5639596f49d2 100644 (file)
@@ -1,3 +1,11 @@
+mmv (1.01b-12.2) unstable; urgency=low
+
+  * NMU
+  * Fix segfault at startup on amd64 (and possibly other architectures)
+    due to implicit declaration of functions from stdlib.h. (Closes: #322541)
+
+ -- Ari Pollak <ari@debian.org>  Sat, 13 Aug 2005 01:01:13 -0400
+
 mmv (1.01b-12.1) unstable; urgency=low
 
   * Non-Maintainer Upload (BSP 2005-08-06).
diff --git a/mmv.c b/mmv.c
index abce4a40b91e82f7642267970502af6b9a8cc7bd..f95772e42f1e28e19cf53e1955afbddb9a8302b2 100644 (file)
--- a/mmv.c
+++ b/mmv.c
@@ -124,6 +124,7 @@ extern unsigned _stklen = 10000;
 #else
 /* for various flavors of UN*X */
 
+#include <stdlib.h>
 #include <sys/types.h>
 #include <sys/stat.h>
 #include <sys/file.h>