]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Mention debhelper (v9) in changelog, add build-dependency
[pkg/mmv.git] / debian / rules
index b70650547c66f271ad44ec3487db76787adc874d..b63827cb7b5e6ef21304d68d0b05d188bb72935a 100755 (executable)
@@ -35,25 +35,23 @@ dir = `pwd`
 
 build:
 # Builds the binary package.
-       $(checkdir)
+       dh_testdir
        $(MAKE) CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
        touch build
 
 clean:
 # Undoes the effect of `make -f debian/rules build'.
-       $(checkdir)
-       [ ! -f Makefile ] || $(MAKE) clean
-       -rm -f debian/files* debian/substvars* debian/*~ core */core *~
-       rm -rf debian/tmp
-       -rm build
+       dh_testdir
+       dh_auto_clean
+       dh_clean build debian/substvars
 
 binary: binary-arch binary-indep
 
 binary-indep:
-       $(checkdir)
+       dh_testdir
 
 binary-arch: build
-       $(checkdir)
+       dh_testdir
        test -f build || $(MAKE) -f debian/rules build
 # Makes a binary package.
        /bin/rm -rf debian/tmp
@@ -63,6 +61,7 @@ binary-arch: build
        install -d -g root -m 755 -o root debian/tmp/DEBIAN
        install -d -g root -m 755 -o root debian/tmp/usr/bin
        install -d -g root -m 755 -o root debian/tmp/usr/share/man/man1
+       install -d -g root -m 755 -o root debian/tmp/usr/share/lintian/overrides
        $(INSTALL_PROGRAM) -g root -o root -m 755 mmv debian/tmp/usr/bin
        test "$(STRIP)" != true || strip \
                --remove-section=.comment --remove-section=.note \
@@ -85,6 +84,8 @@ binary-arch: build
        gzip -f9 debian/tmp/usr/share/doc/$(p)/*
        install -g root -m 644 -o root debian/copyright \
          debian/tmp/usr/share/doc/$(p)
+       install -g root -m 644 -o root debian/lintian-overrides \
+         debian/tmp/usr/share/lintian/overrides/mmv
        chmod -R g-sw debian/tmp/usr/share/doc/$(p)
        chown -R root.root debian/tmp/usr/share/doc/$(p)
        dpkg-shlibdeps debian/tmp/usr/bin/mmv
@@ -92,7 +93,3 @@ binary-arch: build
        cd debian/tmp && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
                 xargs -r0 md5sum > DEBIAN/md5sums
        dpkg --build debian/tmp && dpkg-name -o -s .. debian/tmp.deb
-
-define checkdir
-        test -f mmv.1
-endef