]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Use dh_install
[pkg/mmv.git] / debian / rules
index f175d991e984f3a9c13ad8d0edc258086b9f9203..a92ecf6ae79d2a9eaa42e280eaa472f41395f966 100755 (executable)
@@ -56,13 +56,9 @@ binary-arch: build
        install -d -g root -m 755 -o root debian/tmp
        chmod g-s debian/tmp
        install -d -g root -m 755 -o root debian/tmp/DEBIAN
-       install -d -g root -m 755 -o root debian/tmp/usr/bin
-       install -d -g root -m 755 -o root debian/tmp/usr/share/man/man1
-       install -d -g root -m 755 -o root debian/tmp/usr/share/lintian/overrides
-       install -g root -o root -m 755 mmv debian/tmp/usr/bin
+       dh_install
        dh_strip
-       install -g root -o root -m 644 mmv.1 debian/tmp/usr/share/man/man1
-       gzip -9f debian/tmp/usr/share/man/man1/mmv.1
+       dh_installman
        (cd debian/tmp/usr/bin;\
         ln -s mmv mcp; \
         ln -s mmv mad; \
@@ -74,12 +70,10 @@ binary-arch: build
        install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
        dh_installdocs
        dh_installchangelogs
-       install -g root -m 644 -o root debian/lintian-overrides \
-         debian/tmp/usr/share/lintian/overrides/mmv
-       chmod -R g-sw debian/tmp/usr/share/doc/$(p)
-       chown -R root.root debian/tmp/usr/share/doc/$(p)
-       dpkg-shlibdeps debian/tmp/usr/bin/mmv
-       dpkg-gencontrol -isp
-       cd debian/tmp && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
-                xargs -r0 md5sum > DEBIAN/md5sums
-       dpkg --build debian/tmp && dpkg-name -o -s .. debian/tmp.deb
+       dh_compress
+       dh_lintian
+       dh_fixperms
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb