]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Use dh_auto_install, installs to debian/mmv instead of debian/tmp
[pkg/mmv.git] / debian / rules
index ed99ae4dd293f37a4098d64fcb82f52cb4807fbd..7bfcfaf98001947059dcfc8898f16ec357fa01fa 100755 (executable)
@@ -51,32 +51,25 @@ binary-arch: build
        dh_testdir
        test -f build || $(MAKE) -f debian/rules build
 # Makes a binary package.
-       /bin/rm -rf debian/tmp
        test -f stamp-build || $(MAKE) -f debian/rules build
-       install -d -g root -m 755 -o root debian/tmp
-       chmod g-s debian/tmp
-       install -d -g root -m 755 -o root debian/tmp/DEBIAN
-       install -d -g root -m 755 -o root debian/tmp/usr/bin
-       install -d -g root -m 755 -o root debian/tmp/usr/share/man/man1
-       install -g root -o root -m 755 mmv debian/tmp/usr/bin
+       dh_installdirs
+       dh_auto_install
        dh_strip
-       install -g root -o root -m 644 mmv.1 debian/tmp/usr/share/man/man1
-       gzip -9f debian/tmp/usr/share/man/man1/mmv.1
-       (cd debian/tmp/usr/bin;\
+       (cd debian/mmv/usr/bin;\
         ln -s mmv mcp; \
         ln -s mmv mad; \
         ln -s mmv mln;)
-       (cd debian/tmp/usr/share/man/man1;\
+       (cd debian/mmv/usr/share/man/man1;\
         ln -s mmv.1.gz mcp.1.gz; \
         ln -s mmv.1.gz mad.1.gz; \
         ln -s mmv.1.gz mln.1.gz;)
-       install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
+       install -d -g root -m 755 -o root debian/mmv/usr/share/doc/$(p)
        dh_installdocs
        dh_installchangelogs
+       dh_compress
        dh_lintian
-       chmod -R g-sw debian/tmp/usr/share/doc/$(p)
-       chown -R root.root debian/tmp/usr/share/doc/$(p)
-       dpkg-shlibdeps debian/tmp/usr/bin/mmv
+       dh_fixperms
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
-       dpkg --build debian/tmp && dpkg-name -o -s .. debian/tmp.deb
+       dh_builddeb