]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Imported Debian patch 1.01b-8.1
[pkg/mmv.git] / debian / rules
index c6b78b5bd947541366c616759328efe09290ce57..6f5373c53d55f99ba0d9ba4a1420adaf241c867e 100755 (executable)
@@ -2,6 +2,7 @@
 
 CC = gcc
 LDFLAGS = -s
+CFLAGS = -O2 -g -Wall
 
 # The package
 p = mmv
@@ -15,15 +16,15 @@ dir = `pwd`
 build:
 # Builds the binary package.
        $(checkdir)
-       make CC="$(CC)" LDFLAGS="$(LDFLAGS)"
+       make CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
        touch build
 
 clean:
 # Undoes the effect of `make -f debian/rules build'.
        $(checkdir)
-       make clean
-       /bin/rm -f debian/files* debian/substvars*
-       /bin/rm -rf debian/tmp build
+       -make clean
+       -rm -f debian/files* debian/substvars* debian/*~
+       -rm -rf debian/tmp build
 
 binary: binary-arch binary-indep
 
@@ -64,6 +65,7 @@ binary-arch: build
        chown -R root.root debian/tmp/usr/doc/$(p)
        dpkg-shlibdeps debian/tmp/usr/bin/mmv
        dpkg-gencontrol
+       dh_md5sums
        dpkg --build debian/tmp && dpkg-name -o -s .. debian/tmp.deb
 
 define checkdir