]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Use dh_compress
[pkg/mmv.git] / debian / rules
index 41a93bacb229ddf7f3fe334c128d7207ec0836b6..684c9f87d70482c36858d1ed99345b5fe2921a77 100755 (executable)
@@ -1,18 +1,23 @@
 #! /usr/bin/make -f
 
-INSTALL_PROGRAM=install
 CC = gcc
 LDFLAGS =
-CFLAGS = -O2 -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+CFLAGS = -g -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
 
 
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-CFLAGS += -g
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+    CFLAGS += -O0
+else
+    CFLAGS += -O2
 endif
 
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-INSTALL_PROGRAM += -s
-LDFLAGS += -s
+ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+    LDFLAGS += -s
+endif
+
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(NUMJOBS)
 endif
 
 
@@ -27,34 +32,34 @@ dir = `pwd`
 
 build:
 # Builds the binary package.
-       $(checkdir)
-       make CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
+       dh_testdir
+       $(MAKE) CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
        touch build
 
 clean:
 # Undoes the effect of `make -f debian/rules build'.
-       $(checkdir)
-       -make clean
-       -rm -f debian/files* debian/substvars* debian/*~ core */core *~
-       -rm -rf debian/tmp build
+       dh_testdir
+       dh_auto_clean
+       dh_clean build debian/substvars
 
 binary: binary-arch binary-indep
 
 binary-indep:
-       $(checkdir)
+       dh_testdir
 
 binary-arch: build
-       $(checkdir)
-       test -f build || make -f debian/rules build
+       dh_testdir
+       test -f build || $(MAKE) -f debian/rules build
 # Makes a binary package.
        /bin/rm -rf debian/tmp
-       test -f stamp-build || make -f debian/rules build
+       test -f stamp-build || $(MAKE) -f debian/rules build
        install -d -g root -m 755 -o root debian/tmp
        chmod g-s debian/tmp
        install -d -g root -m 755 -o root debian/tmp/DEBIAN
        install -d -g root -m 755 -o root debian/tmp/usr/bin
        install -d -g root -m 755 -o root debian/tmp/usr/share/man/man1
-       $(INSTALL_PROGRAM) -g root -o root -m 755 mmv debian/tmp/usr/bin
+       install -g root -o root -m 755 mmv debian/tmp/usr/bin
+       dh_strip
        install -g root -o root -m 644 mmv.1 debian/tmp/usr/share/man/man1
        gzip -9f debian/tmp/usr/share/man/man1/mmv.1
        (cd debian/tmp/usr/bin;\
@@ -66,20 +71,13 @@ binary-arch: build
         ln -s mmv.1.gz mad.1.gz; \
         ln -s mmv.1.gz mln.1.gz;)
        install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
-       install -g root -m 644 -o root READ.ME \
-               debian/tmp/usr/share/doc/$(p)
-       install -g root -m 644 -o root debian/changelog \
-               debian/tmp/usr/share/doc/$(p)/changelog.Debian
-       gzip -f9 debian/tmp/usr/share/doc/$(p)/*
-       install -g root -m 644 -o root debian/copyright \
-         debian/tmp/usr/share/doc/$(p)
+       dh_installdocs
+       dh_installchangelogs
+       dh_compress
+       dh_lintian
        chmod -R g-sw debian/tmp/usr/share/doc/$(p)
        chown -R root.root debian/tmp/usr/share/doc/$(p)
-       dpkg-shlibdeps debian/tmp/usr/bin/mmv
-       dpkg-gencontrol -isp
+       dh_shlibdeps
+       dh_gencontrol
        dh_md5sums
-       dpkg --build debian/tmp && dpkg-name -o -s .. debian/tmp.deb
-
-define checkdir
-        test -f mmv.1
-endef
+       dh_builddeb