]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Remove ancient comments and blank lines from debian/rules
[pkg/mmv.git] / debian / rules
index fdfc5c45dc885f3fbe8fba56625d257af82e4802..4c148b5339a25805851cf5369d66f884f4612b45 100755 (executable)
@@ -3,26 +3,24 @@
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/buildflags.mk
 
-build:
-# Builds the binary package.
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp:
        dh_testdir
-       $(MAKE) CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
-       touch build
+       dh_auto_build -- LDFLAGS="$(LDFLAGS)"
 
 clean:
-# Undoes the effect of `make -f debian/rules build'.
        dh_testdir
        dh_auto_clean
-       dh_clean build debian/substvars
+       dh_clean
 
 binary: binary-arch binary-indep
-
 binary-indep:
        dh_testdir
 
 binary-arch: build
        dh_testdir
-# Makes a binary package.
        dh_installdirs
        dh_auto_install
        dh_strip