]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Remove ancient comments and blank lines from debian/rules
[pkg/mmv.git] / debian / rules
index cbfa5f44da99a92e03a049fc75ed7efd1fdb3fda..4c148b5339a25805851cf5369d66f884f4612b45 100755 (executable)
@@ -1,62 +1,30 @@
 #! /usr/bin/make -f
 
-CC = gcc
-LDFLAGS =
-CFLAGS = -g -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
 
-
-ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
-    CFLAGS += -O0
-else
-    CFLAGS += -O2
-endif
-
-ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
-    LDFLAGS += -s
-endif
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    MAKEFLAGS += -j$(NUMJOBS)
-endif
-
-
-# The package
-p = mmv
-# The version
-v = $(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
-# The architecture
-a = $(shell dpkg --print-architecture)
-
-dir = `pwd`
-
-build:
-# Builds the binary package.
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp:
        dh_testdir
-       $(MAKE) CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
-       touch build
+       dh_auto_build -- LDFLAGS="$(LDFLAGS)"
 
 clean:
-# Undoes the effect of `make -f debian/rules build'.
        dh_testdir
        dh_auto_clean
-       dh_clean build debian/substvars
+       dh_clean
 
 binary: binary-arch binary-indep
-
 binary-indep:
        dh_testdir
 
 binary-arch: build
        dh_testdir
-       test -f build || $(MAKE) -f debian/rules build
-# Makes a binary package.
-       test -f stamp-build || $(MAKE) -f debian/rules build
        dh_installdirs
        dh_auto_install
        dh_strip
        dh_link
-       install -d -g root -m 755 -o root debian/mmv/usr/share/doc/$(p)
        dh_installdocs
        dh_installchangelogs
        dh_compress