]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Use dh_auto_build
[pkg/mmv.git] / debian / rules
index 82666b8056750f63a4995f59d81971ad92931d82..409795105c20193dd2a7b1b13c7e0f59363e3827 100755 (executable)
@@ -1,86 +1,40 @@
 #! /usr/bin/make -f
 
-INSTALL_PROGRAM=install
-CC = gcc
-LDFLAGS =
-CFLAGS = -O2 -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
 
-
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-CFLAGS += -g
-endif
-
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-INSTALL_PROGRAM += -s
-LDFLAGS += -s
-endif
-
-
-# The package
-p = mmv
-# The version
-v = $(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
-# The architecture
-a = $(shell dpkg --print-architecture)
-
-dir = `pwd`
-
-build:
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp:
 # Builds the binary package.
-       $(checkdir)
-       make CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
-       touch build
+       dh_testdir
+       dh_auto_build -- LDFLAGS="$(LDFLAGS)"
 
 clean:
 # Undoes the effect of `make -f debian/rules build'.
-       $(checkdir)
-       -make clean
-       -rm -f debian/files* debian/substvars* debian/*~ core */core *~
-       rm -rf debian/tmp
-       -rm build
+       dh_testdir
+       dh_auto_clean
+       dh_clean
 
 binary: binary-arch binary-indep
 
 binary-indep:
-       $(checkdir)
+       dh_testdir
 
 binary-arch: build
-       $(checkdir)
-       test -f build || make -f debian/rules build
+       dh_testdir
 # Makes a binary package.
-       /bin/rm -rf debian/tmp
-       test -f stamp-build || make -f debian/rules build
-       install -d -g root -m 755 -o root debian/tmp
-       chmod g-s debian/tmp
-       install -d -g root -m 755 -o root debian/tmp/DEBIAN
-       install -d -g root -m 755 -o root debian/tmp/usr/bin
-       install -d -g root -m 755 -o root debian/tmp/usr/share/man/man1
-       $(INSTALL_PROGRAM) -g root -o root -m 755 mmv debian/tmp/usr/bin
-       install -g root -o root -m 644 mmv.1 debian/tmp/usr/share/man/man1
-       gzip -9f debian/tmp/usr/share/man/man1/mmv.1
-       (cd debian/tmp/usr/bin;\
-        ln -s mmv mcp; \
-        ln -s mmv mad; \
-        ln -s mmv mln;)
-       (cd debian/tmp/usr/share/man/man1;\
-        ln -s mmv.1.gz mcp.1.gz; \
-        ln -s mmv.1.gz mad.1.gz; \
-        ln -s mmv.1.gz mln.1.gz;)
-       install -d -g root -m 755 -o root debian/tmp/usr/share/doc/$(p)
-       install -g root -m 644 -o root READ.ME \
-               debian/tmp/usr/share/doc/$(p)
-       install -g root -m 644 -o root debian/changelog \
-               debian/tmp/usr/share/doc/$(p)/changelog.Debian
-       gzip -f9 debian/tmp/usr/share/doc/$(p)/*
-       install -g root -m 644 -o root debian/copyright \
-         debian/tmp/usr/share/doc/$(p)
-       chmod -R g-sw debian/tmp/usr/share/doc/$(p)
-       chown -R root.root debian/tmp/usr/share/doc/$(p)
-       dpkg-shlibdeps debian/tmp/usr/bin/mmv
-       dpkg-gencontrol -isp
+       dh_installdirs
+       dh_auto_install
+       dh_strip
+       dh_link
+       dh_installdocs
+       dh_installchangelogs
+       dh_compress
+       dh_lintian
+       dh_fixperms
+       dh_shlibdeps
+       dh_gencontrol
        dh_md5sums
-       dpkg --build debian/tmp && dpkg-name -o -s .. debian/tmp.deb
-
-define checkdir
-        test -f mmv.1
-endef
+       dh_builddeb