]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Use dh_auto_build
[pkg/mmv.git] / debian / rules
index 7bfcfaf98001947059dcfc8898f16ec357fa01fa..409795105c20193dd2a7b1b13c7e0f59363e3827 100755 (executable)
@@ -1,46 +1,21 @@
 #! /usr/bin/make -f
 
-CC = gcc
-LDFLAGS =
-CFLAGS = -g -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
 
-
-ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
-    CFLAGS += -O0
-else
-    CFLAGS += -O2
-endif
-
-ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
-    LDFLAGS += -s
-endif
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    MAKEFLAGS += -j$(NUMJOBS)
-endif
-
-
-# The package
-p = mmv
-# The version
-v = $(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
-# The architecture
-a = $(shell dpkg --print-architecture)
-
-dir = `pwd`
-
-build:
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp:
 # Builds the binary package.
        dh_testdir
-       $(MAKE) CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)"
-       touch build
+       dh_auto_build -- LDFLAGS="$(LDFLAGS)"
 
 clean:
 # Undoes the effect of `make -f debian/rules build'.
        dh_testdir
        dh_auto_clean
-       dh_clean build debian/substvars
+       dh_clean
 
 binary: binary-arch binary-indep
 
@@ -49,21 +24,11 @@ binary-indep:
 
 binary-arch: build
        dh_testdir
-       test -f build || $(MAKE) -f debian/rules build
 # Makes a binary package.
-       test -f stamp-build || $(MAKE) -f debian/rules build
        dh_installdirs
        dh_auto_install
        dh_strip
-       (cd debian/mmv/usr/bin;\
-        ln -s mmv mcp; \
-        ln -s mmv mad; \
-        ln -s mmv mln;)
-       (cd debian/mmv/usr/share/man/man1;\
-        ln -s mmv.1.gz mcp.1.gz; \
-        ln -s mmv.1.gz mad.1.gz; \
-        ln -s mmv.1.gz mln.1.gz;)
-       install -d -g root -m 755 -o root debian/mmv/usr/share/doc/$(p)
+       dh_link
        dh_installdocs
        dh_installchangelogs
        dh_compress