]> git.deb.at Git - pkg/mmv.git/blobdiff - debian/rules
Use hardening build flags
[pkg/mmv.git] / debian / rules
index e2f6fba0d75c167ecc86ecf8e7a04820aacad2d8..fdfc5c45dc885f3fbe8fba56625d257af82e4802 100755 (executable)
@@ -1,23 +1,7 @@
 #! /usr/bin/make -f
 
-LDFLAGS =
-CFLAGS = -g -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-
-
-ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
-    CFLAGS += -O0
-else
-    CFLAGS += -O2
-endif
-
-ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
-    LDFLAGS += -s
-endif
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    MAKEFLAGS += -j$(NUMJOBS)
-endif
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
 
 build:
 # Builds the binary package.