]> git.deb.at Git - pkg/beep.git/blobdiff - debian/rules
Imported Debian patch 1.2.2-21
[pkg/beep.git] / debian / rules
index ba09d0a1491652dd88b6c22789b1bfa38b80491c..b21dd92dd3f53857ba5c04fe22a4c94951838612 100755 (executable)
@@ -25,6 +25,7 @@ else
 endif
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
+       STRIP = true
 endif
 
 
@@ -34,7 +35,7 @@ clean: unpatch
        $(checkdir)
        $(checkroot)
        -rm -rf $(TMP1) $(TMP2) debian/substvars debian/files build-stamp
-       -$(MAKE) clean
+       [ ! -f beep ] || $(MAKE) clean
 
 
 build: build-stamp
@@ -63,6 +64,9 @@ install: build
        cd $(TMP1)/usr/share/doc/$(PKG1) && gzip -9 changelog README
        $(INSTALL_DIR) $(TMP2)/usr/bin
        $(INSTALL_PROGRAM) beep $(TMP2)/usr/bin
+       test "$(STRIP)" != true || strip \
+               --remove-section=.comment --remove-section=.note \
+               $(TMP1)/usr/bin/beep $(TMP2)/usr/bin/beep
 
 
 # Build architecture-independent files here.