]> git.deb.at Git - pkg/abook.git/blobdiff - debian/rules
switch to debhelper
[pkg/abook.git] / debian / rules
index 0d36a2f7f126f0175dfc09d890a786b6d2563c0a..94ee65cfa4e7081a89edb039f52a31a7184a8cd4 100755 (executable)
@@ -1,96 +1,12 @@
 #!/usr/bin/make -f
-# debian/rules for abook
-PACKAGE = abook
-TMP = $(CURDIR)/debian/$(PACKAGE)
+#DH_VERBOSE = 1
 
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
 
-CFLAGS = -g -Wall
-INSTALL = install
-INSTALL_FILE    = $(INSTALL) -p    -oroot -groot -m644
-INSTALL_PROGRAM = $(INSTALL) -p    -oroot -groot -m755
-INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
-INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-       INSTALL_PROGRAM += -s
-endif
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND  = -g -Wall -pedantic -std=gnu89
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-clean:
-       $(checkdir)
-       $(checkroot)
-       rm -rf build-stamp $(TMP) debian/files debian/substvars
-       -$(MAKE) distclean
-
-
-build: build-stamp
-build-stamp:
-       $(checkdir)
-       ./configure --prefix=/usr --mandir=\$${prefix}/share/man \
-                --infodir=\$${prefix}/share/info
-       $(MAKE) CFLAGS="$(CFLAGS)"
-       touch build-stamp
-
-
-install: build
-       $(checkdir)
-       $(checkroot)
-       -rm -rf $(TMP)
-       $(INSTALL_DIR) $(TMP)
-       cd $(TMP) && $(INSTALL_DIR) usr/share/doc/$(PACKAGE)/examples
-       $(MAKE) prefix=$(TMP)/usr install INSTALL_PROGRAM="$(INSTALL_PROGRAM)"
-       $(INSTALL_FILE) ChangeLog $(TMP)/usr/share/doc/$(PACKAGE)/changelog
-       $(INSTALL_FILE) ANNOUNCE AUTHORS BUGS FAQ README THANKS TODO \
-               $(TMP)/usr/share/doc/$(PACKAGE)
-       $(INSTALL_FILE) sample.abookrc \
-               $(TMP)/usr/share/doc/$(PACKAGE)/examples
-       cd $(TMP)/usr/share && gzip -9 man/man1/abook.1 man/man5/abookrc.5 \
-               doc/$(PACKAGE)/changelog
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       $(checkdir)
-       $(checkroot)
-       $(INSTALL_DIR) $(TMP)/DEBIAN $(TMP)/usr/share/menu
-       $(INSTALL_FILE) debian/menu $(TMP)/usr/share/menu/$(PACKAGE)
-       $(INSTALL_FILE) debian/copyright $(TMP)/usr/share/doc/$(PACKAGE)
-       $(INSTALL_FILE) debian/changelog \
-               $(TMP)/usr/share/doc/$(PACKAGE)/changelog.Debian
-       gzip -9 $(TMP)/usr/share/doc/$(PACKAGE)/changelog.Debian
-       $(INSTALL_SCRIPT) debian/config debian/postinst debian/postrm \
-               $(TMP)/DEBIAN
-       po2debconf debian/templates > $(TMP)/DEBIAN/templates
-       dpkg-shlibdeps -Tdebian/substvars -dDepends $(TMP)/usr/bin/abook
-       dpkg-gencontrol -ldebian/changelog -isp -Tdebian/substvars \
-               -p$(PACKAGE) -P$(TMP)
-       cd $(TMP) && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
-               xargs -r0 md5sum > DEBIAN/md5sums
-       dpkg --build $(TMP) ..
-
-
-binary: binary-indep binary-arch
-
-
-define checkdir
-       test -f debian/rules
-endef
-
-define checkroot
-       test root = "`whoami`"
-endef
-
-.PHONY: clean build install binary-indep binary-arch binary
+%:
+       dh $@