]> git.deb.at Git - pkg/abook.git/blobdiff - debian/rules
set -e on its own line
[pkg/abook.git] / debian / rules
index 96f875af9131f666f515530d5ee3e2eeb217bebd..02a2a7c9562f44101316f99b72abb29f1c6ef76a 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for abook
-# copyright 2003-2009 by Gerfried Fuchs <rhonda@debian.at>
-# Licenced under BSD style
+# copyright 2003-2012 by Gerfried Fuchs <rhonda@debian.org>
+# Licenced under WTFPLv2
 
 PKG = abook
 TMP = $(CURDIR)/debian/$(PKG)
@@ -58,8 +58,7 @@ install: build
        $(checkroot)
        -rm -rf $(TMP)
        $(INSTALL_DIR) $(TMP)
-       cd $(TMP) && $(INSTALL_DIR) usr/share/doc/$(PKG)/examples \
-               usr/share/doc/$(PKG)/contrib
+       cd $(TMP) && $(INSTALL_DIR) usr/share/doc/$(PKG)/examples
        $(MAKE) prefix=$(TMP)/usr install INSTALL_PROGRAM="$(INSTALL_PROGRAM)"
        test "$(STRIP)" != true || strip \
                --remove-section=.comment --remove-section=.note \
@@ -67,13 +66,10 @@ install: build
        $(INSTALL_FILE) ChangeLog $(TMP)/usr/share/doc/$(PKG)/changelog
        $(INSTALL_FILE) ANNOUNCE AUTHORS BUGS FAQ README THANKS TODO \
                $(TMP)/usr/share/doc/$(PKG)
-       $(INSTALL_FILE) sample.abookrc contrib/mail2abook.py \
-               contrib/vcard2abook.pl $(TMP)/usr/share/doc/$(PKG)/examples
-       $(INSTALL_FILE) contrib/abook+vim/README contrib/abook+vim/mail.vim \
-               $(TMP)/usr/share/doc/$(PKG)/contrib
+       $(INSTALL_FILE) sample.abookrc \
+               $(TMP)/usr/share/doc/$(PKG)/examples
        cd $(TMP)/usr/share && gzip -9 man/man1/abook.1 man/man5/abookrc.5 \
-               doc/$(PKG)/examples/mail2abook.py doc/$(PKG)/changelog \
-               doc/$(PKG)/contrib/mail.vim
+               doc/$(PKG)/changelog
 
 
 # Build architecture-independent files here.