]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Convert debian/rules to dh style
[pkg/t-prot.git] / debian / rules
index bd83c2845aae70b6474a67966b6f28c603cb8697..f4257007c89beca7a0ae3646bc46b4f79b816802 100755 (executable)
@@ -1,91 +1,8 @@
 #!/usr/bin/make -f
-# debian/rules for t-prot package
+#DH_VERBOSE = 1
 
-PACKAGE = t-prot
-TMP = $(CURDIR)/debian/$(PACKAGE)
 
-INSTALL = install
-INSTALL_FILE    = $(INSTALL) -p    -oroot -groot -m644
-INSTALL_PROGRAM = $(INSTALL) -p    -oroot -groot -m755
-INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
-INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
-
-
-clean:
-       $(checkdir)
-       $(checkroot)
-       -rm -rf $(TMP) debian/files
-
-
-build:
-       # uhm, build for a binary-indep package?  Don't try to be funny ;)
-
-
-install: build
-       $(checkdir)
-       $(checkroot)
-       -rm -rf $(TMP)
-       $(INSTALL_DIR) $(TMP)
-       cd $(TMP) && $(INSTALL_DIR) etc usr/bin usr/share/man/man1 \
-               usr/share/slrn/macros usr/share/doc/$(PACKAGE)/examples
-       #       usr/share/doc/$(PACKAGE)/contrib
-       $(INSTALL_SCRIPT) t-prot   $(TMP)/usr/bin
-       cd $(TMP)/usr/bin/ && patch t-prot \
-               $(TMP)/../../contrib/t-prot-r*-mutt157.diff
-       $(INSTALL_FILE)   t-prot.1 $(TMP)/usr/share/man/man1
-       $(INSTALL_FILE) debian/Muttrc.t-prot $(TMP)/etc
-       $(INSTALL_FILE) contrib/t-prot.sl $(TMP)/usr/share/slrn/macros
-
-       $(INSTALL_FILE) BUGS TODO README $(TMP)/usr/share/doc/$(PACKAGE)
-       #$(INSTALL_FILE) contrib/README.patches contrib/t-prot-r*-gol.diff \
-       #       contrib/t-prot-r*-indentms.diff \
-       #       $(TMP)/usr/share/doc/$(PACKAGE)/contrib
-       cp -pR contrib/muttrc.t-prot contrib/filter_innd.pl debian/footers \
-               debian/README.footers \
-               $(TMP)/usr/share/doc/$(PACKAGE)/examples
-       $(INSTALL_FILE) ChangeLog \
-               $(TMP)/usr/share/doc/$(PACKAGE)/changelog
-       cd $(TMP)/usr/share && gzip -9 doc/$(PACKAGE)/changelog \
-               man/man1/t-prot.1
-       find $(TMP) -print0 2>/dev/null | xargs -0r \
-               chown --no-dereference 0.0
-       find $(TMP) ! -type l -print0 2>/dev/null | xargs -0r \
-               chmod go=rX,u+rw,a-s
-
-
-binary-indep: build install
-       $(checkdir)
-       $(checkroot)
-       $(INSTALL_DIR) $(TMP)/DEBIAN
-       $(INSTALL_FILE) debian/copyright debian/README.Debian \
-               debian/NEWS.Debian $(TMP)/usr/share/doc/$(PACKAGE)
-       $(INSTALL_FILE) debian/changelog \
-               $(TMP)/usr/share/doc/$(PACKAGE)/changelog.Debian
-       cd $(TMP)/usr/share/doc/$(PACKAGE) && gzip -9 \
-               changelog.Debian NEWS.Debian
-       $(INSTALL_SCRIPT) debian/postinst \
-               $(TMP)/DEBIAN
-       $(INSTALL_FILE) debian/conffiles \
-               $(TMP)/DEBIAN
-       dpkg-gencontrol -ldebian/changelog -isp -p$(PACKAGE) -P$(TMP)
-       cd $(TMP) && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
-               xargs -r0 md5sum > DEBIAN/md5sums
-       dpkg --build $(TMP) ..
-
-
-binary-arch: build install
-       # We have nothing to do here.
-
-
-binary: binary-indep binary-arch
-
-
-define checkdir
-       test -f debian/rules
-endef
-
-define checkroot
-       test root = "`whoami`"
-endef
-
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@
+       # not sure about override for po2debconf needed
+       # po2debconf debian/templates > $(TMP)/DEBIAN/templates