]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Drop build-dependencies on patch and quilt as there are no more patches
[pkg/t-prot.git] / debian / rules
index f55ee4ace36389d4cc5aee320f25df0c5967c245..e6e05773232c48dbb508468f29ca9edcf991ea39 100755 (executable)
@@ -22,7 +22,7 @@ build: build-arch build-indep
 build-arch: debian/stamp-build
 build-indep: debian/stamp-build
 debian/stamp-build:
-       # uhm, build for a binary-indep package?  Don't try to be funny ;)
+       # only thing to do is apply the patches ...
        touch debian/stamp-build
 
 
@@ -37,16 +37,10 @@ debian/stamp-install: build
                usr/share/doc/$(PKG)/examples
        #       usr/share/doc/$(PKG)/contrib
        $(INSTALL_SCRIPT) t-prot   $(TMP)/usr/bin
-       patch $(TMP)/usr/bin/t-prot \
-               contrib/t-prot-r*-mutt15*.diff
-       -rm -f $(TMP)/usr/bin/t-prot.orig
        $(INSTALL_FILE)   t-prot.1 $(TMP)/usr/share/man/man1
        $(INSTALL_FILE) debian/Muttrc     $(TMP)/etc/t-prot
        $(INSTALL_FILE) debian/footers/*  $(TMP)/etc/t-prot/footers
        $(INSTALL_FILE) contrib/t-prot.sl $(TMP)/usr/share/slrn/macros
-       patch $(TMP)/usr/share/slrn/macros/t-prot.sl \
-               contrib/t-prot.sl-slang2.diff
-       -rm -f $(TMP)/usr/share/slrn/macros/t-prot.sl.orig
 
        $(INSTALL_FILE) TODO README $(TMP)/usr/share/doc/$(PKG)
        #$(INSTALL_FILE) contrib/README.patches contrib/t-prot-r*-gol.diff \