]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Imported Debian patch 2.1-2
[pkg/t-prot.git] / debian / rules
index d829176f8a68a1fe77519a1be3072c87d936aee3..e43c585786cd1185a5fa3865c4cf3b03d1ef2284 100755 (executable)
@@ -26,15 +26,17 @@ install: build
        $(checkroot)
        -rm -rf $(TMP)
        $(INSTALL_DIR) $(TMP)
-       cd $(TMP) && $(INSTALL_DIR) etc usr/bin usr/share/man/man1 \
-               usr/share/slrn/macros usr/share/doc/$(PKG)/examples
+       cd $(TMP) && $(INSTALL_DIR) etc/t-prot/footers etc/t-prot/ads \
+               usr/bin usr/share/man/man1 usr/share/slrn/macros \
+               usr/share/doc/$(PKG)/examples
        #       usr/share/doc/$(PKG)/contrib
        $(INSTALL_SCRIPT) t-prot   $(TMP)/usr/bin
        patch $(TMP)/usr/bin/t-prot \
                contrib/t-prot-r*-mutt157.diff
        -rm -f $(TMP)/usr/bin/t-prot.orig
        $(INSTALL_FILE)   t-prot.1 $(TMP)/usr/share/man/man1
-       $(INSTALL_FILE) debian/Muttrc.t-prot $(TMP)/etc
+       $(INSTALL_FILE) debian/Muttrc     $(TMP)/etc/t-prot
+       $(INSTALL_FILE) debian/footers/*  $(TMP)/etc/t-prot/footers
        $(INSTALL_FILE) contrib/t-prot.sl $(TMP)/usr/share/slrn/macros
        patch $(TMP)/usr/share/slrn/macros/t-prot.sl \
                contrib/t-prot.sl-slang2.diff
@@ -44,17 +46,12 @@ install: build
        #$(INSTALL_FILE) contrib/README.patches contrib/t-prot-r*-gol.diff \
        #       contrib/t-prot-r*-indentms.diff \
        #       $(TMP)/usr/share/doc/$(PKG)/contrib
-       cp -pR contrib/muttrc.t-prot contrib/filter_innd.pl \
-               contrib/README.examples debian/footers debian/README.footers \
+       $(INSTALL_FILE) contrib/filter_innd.pl contrib/README.examples \
                $(TMP)/usr/share/doc/$(PKG)/examples
        $(INSTALL_FILE) ChangeLog \
                $(TMP)/usr/share/doc/$(PKG)/changelog
        cd $(TMP)/usr/share && gzip -9 doc/$(PKG)/changelog \
                man/man1/t-prot.1
-       find $(TMP) -print0 2>/dev/null | xargs -0r \
-               chown --no-dereference 0.0
-       find $(TMP) ! -type l -print0 2>/dev/null | xargs -0r \
-               chmod go=rX,u+rw,a-s
 
 
 binary-indep: build install