]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Imported Debian patch 2.5-2
[pkg/t-prot.git] / debian / rules
index 249f0d8c481fa6d7cf3fed16b3200b4ba850b996..4ef43b5f02e13ef897139345f6f919ef439cd9c1 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 # debian/rules for t-prot package
-# (c) 2002-2007 by Gerfried Fuchs <rhonda@debian.at>
+# (c) 2002-2008 by Gerfried Fuchs <rhonda@debian.at>
 # Licenced in the same way as t-prot itself
 
 PKG = t-prot
@@ -13,14 +13,18 @@ INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
 INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
 
 
-clean:
+include /usr/share/quilt/quilt.make
+
+clean: unpatch
        $(checkdir)
        $(checkroot)
-       -rm -rf $(TMP) debian/files
+       -rm -rf $(TMP) debian/files build-stamp
 
 
-build:
+build-stamp: build
+build: patch
        # uhm, build for a binary-indep package?  Don't try to be funny ;)
+       touch build-stamp
 
 
 install: build