]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Imported Debian patch 2.8-1
[pkg/t-prot.git] / debian / rules
index 249f0d8c481fa6d7cf3fed16b3200b4ba850b996..25d659313cfe31cfe25d895d73578c5bfd1e9c23 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for t-prot package
-# (c) 2002-2007 by Gerfried Fuchs <rhonda@debian.at>
-# Licenced in the same way as t-prot itself
+# Copyright 2002-2009 by Gerfried Fuchs <rhonda@debian.at>
+# Licenced BSD style
 
 PKG = t-prot
 TMP = $(CURDIR)/debian/$(PKG)
@@ -13,14 +13,18 @@ INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
 INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
 
 
-clean:
+include /usr/share/quilt/quilt.make
+
+clean: unpatch
        $(checkdir)
        $(checkroot)
-       -rm -rf $(TMP) debian/files
+       -rm -rf $(TMP) debian/files build-stamp
 
 
-build:
+build-stamp: build
+build: patch
        # uhm, build for a binary-indep package?  Don't try to be funny ;)
+       touch build-stamp
 
 
 install: build
@@ -61,11 +65,11 @@ binary-indep: build install
        $(checkroot)
        $(INSTALL_DIR) $(TMP)/DEBIAN
        $(INSTALL_FILE) debian/copyright debian/README.Debian \
-               debian/NEWS.Debian $(TMP)/usr/share/doc/$(PKG)
+               $(TMP)/usr/share/doc/$(PKG)
        $(INSTALL_FILE) debian/changelog \
                $(TMP)/usr/share/doc/$(PKG)/changelog.Debian
        cd $(TMP)/usr/share/doc/$(PKG) && gzip -9 \
-               changelog.Debian NEWS.Debian
+               changelog.Debian
        $(INSTALL_SCRIPT) debian/postinst debian/postrm debian/config \
                $(TMP)/DEBIAN
        po2debconf debian/templates > $(TMP)/DEBIAN/templates
@@ -77,11 +81,11 @@ binary-indep: build install
        dpkg --build $(TMP) ..
 
 
-binary-arch: build install
+binary-arch:
        # We have nothing to do here.
 
 
-binary: binary-indep binary-arch
+binary: binary-indep
 
 
 define checkdir