]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
New upstream release; drop no more needed patches
[pkg/t-prot.git] / debian / rules
index 63edcc94c7e1bb667bcfff5ca74a86409d1451ad..1c075f50f7633a62eff0223f072156d6fe086dab 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for t-prot package
-# Copyright 2002-2009 by Gerfried Fuchs <rhonda@debian.at>
-# Licenced BSD style
+# Copyright 2002-2012 by Gerfried Fuchs <rhonda@debian.org>
+# Licenced under WTFPLv2
 
 PKG = t-prot
 TMP = $(CURDIR)/debian/$(PKG)
@@ -16,16 +16,20 @@ INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
 clean:
        $(checkdir)
        $(checkroot)
-       -rm -rf $(TMP) debian/files build-stamp
+       -rm -rf $(TMP) debian/files debian/stamp-*
+       $(MAKE) -f /usr/share/quilt/quilt.make unpatch
 
+build: build-arch build-indep
+build-arch: debian/stamp-build
+build-indep: debian/stamp-build
+debian/stamp-build:
+       # only thing to do is apply the patches ...
+       $(MAKE) -f /usr/share/quilt/quilt.make patch
+       touch debian/stamp-build
 
-build-stamp: build
-build:
-       # uhm, build for a binary-indep package?  Don't try to be funny ;)
-       touch build-stamp
 
-
-install: build
+install: debian/stamp-install
+debian/stamp-install: build
        $(checkdir)
        $(checkroot)
        -rm -rf $(TMP)
@@ -35,16 +39,10 @@ install: build
                usr/share/doc/$(PKG)/examples
        #       usr/share/doc/$(PKG)/contrib
        $(INSTALL_SCRIPT) t-prot   $(TMP)/usr/bin
-       patch $(TMP)/usr/bin/t-prot \
-               contrib/t-prot-r*-mutt15*.diff
-       -rm -f $(TMP)/usr/bin/t-prot.orig
        $(INSTALL_FILE)   t-prot.1 $(TMP)/usr/share/man/man1
        $(INSTALL_FILE) debian/Muttrc     $(TMP)/etc/t-prot
        $(INSTALL_FILE) debian/footers/*  $(TMP)/etc/t-prot/footers
        $(INSTALL_FILE) contrib/t-prot.sl $(TMP)/usr/share/slrn/macros
-       patch $(TMP)/usr/share/slrn/macros/t-prot.sl \
-               contrib/t-prot.sl-slang2.diff
-       -rm -f $(TMP)/usr/share/slrn/macros/t-prot.sl.orig
 
        $(INSTALL_FILE) TODO README $(TMP)/usr/share/doc/$(PKG)
        #$(INSTALL_FILE) contrib/README.patches contrib/t-prot-r*-gol.diff \
@@ -58,7 +56,7 @@ install: build
                man/man1/t-prot.1
 
 
-binary-indep: build install
+binary-indep: install
        $(checkdir)
        $(checkroot)
        $(INSTALL_DIR) $(TMP)/DEBIAN