]> git.deb.at Git - pkg/netris.git/commitdiff
Imported Debian patch 0.52-3 debian/0.52-3
authorGerfried Fuchs <alfie@debian.org>
Fri, 18 Mar 2005 17:04:22 +0000 (18:04 +0100)
committerGerfried Fuchs <rhonda@debian.at>
Wed, 14 Jul 2010 19:42:29 +0000 (21:42 +0200)
debian/README.Debian
debian/changelog
debian/control
debian/copyright
debian/menu
game.c

index e07eb0a330c42aac0e974e5e2932944f6f20cde9..3dd13afb6fa6c586a8f6667f7eed208123ca779d 100644 (file)
@@ -2,12 +2,12 @@ netris for Debian
 -----------------
 
  I did apply the "new game" patch from Tomas Berndtsson <tomas@nocrew.org>.
-This patch is really nice for it multiplayer games, you don't have to exit and
-can press 'n' (or whatever key you bound the function to) to start a new game.
-For the keybinding stuff I had to patch the patch myself ,-)
+This patch is really nice because in multiplayer games, you don't have to exit
+and can press 'n' (or whatever key you bound the function to) to start a new
+game.  For the keybinding stuff I had to patch the patch myself ,-)
 
  I have contacted the upstream maintainer about this patch in June but haven't
-heard from him since then.  Last contact I had with Mark was in march.  If you
+heard from him since then.  Last contact I had with Mark was in March.  If you
 have any information about him feel free to contact me.
 
  Ah, and I have another patch sent in by Rob Hensley <zoid@staticky.com>
index 7a4f992df79034ce4deffb3a5c3d7c1eb0c4e573..c55d7719d1b05f837ec427967fb048daebc5aa05 100644 (file)
@@ -1,3 +1,12 @@
+netris (0.52-3) unstable; urgency=low
+
+  * Quote all entries in the menu file.
+  * Fix -s setting, patch from Piotr Krukowiecki, thanks (closes: #300125)
+  * Fixed short description to not include an upercased article at the start.
+  * Slightly reformated copyright file a bit.
+
+ -- Gerfried Fuchs <alfie@debian.org>  Fri, 18 Mar 2005 18:04:22 +0100
+
 netris (0.52-2) unstable; urgency=low
 
   * Applied patch from Per von Zweigbergk for staircase effect (closes: #83039)
index ee5b88d528829811aeccbd0712bcf60e6f96826d..8df77ff1fb333938242ebec587868bc1c0a39a41 100644 (file)
@@ -8,7 +8,7 @@ Standards-Version: 3.6.1
 Package: netris
 Architecture: any
 Depends: ${shlibs:Depends}
-Description: free, networked version of T*tris
+Description: free, networked version of T*tris
  Netris is a free, networked variant of Tetris.
  .
  One-player mode is a tad boring at the moment because it never
index f61f2a18483c09ea502cf81f30edda202aa02970..d677c00f548ba528b7fa3e275286c7f30e113b61 100644 (file)
@@ -1,28 +1,24 @@
-This package was debianized by Gergely Madarasz <gorgo@caesar.elte.hu> on
+This package was first debianized by Gergely Madarasz <gorgo@caesar.elte.hu> on
 Wed,  6 Aug 1997 22:10:42 +0200.
 
 It was downloaded from ftp://ftp.netris.org/pub/netris/
 
-Changes:
- * added Debian GNU/Linux package maintenance system files
- * modified Configure script for use with ncurses
-
-Copyright (C) 1994,1995,1996  Mark H. Weaver <mhw@netris.org>
-
-This program is free software; you can redistribute it and/or modify it
-under the terms of the GNU General Public License as published by the
-Free Software Foundation; either version 2, or (at your option) any
-later version.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program; if not, write to the Free Software
-Foundation, 59 Temple Place - Suite 330,
-Boston, MA 02111-1307, USA.
+    Copyright (C) 1994,1995,1996  Mark H. Weaver <mhw@netris.org>
+    
+    This program is free software; you can redistribute it and/or modify it
+    under the terms of the GNU General Public License as published by the
+    Free Software Foundation; either version 2, or (at your option) any
+    later version.
+    
+    This program is distributed in the hope that it will be useful,
+    but WITHOUT ANY WARRANTY; without even the implied warranty of
+    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+    GNU General Public License for more details.
+    
+    You should have received a copy of the GNU General Public License
+    along with this program; if not, write to the Free Software
+    Foundation, 59 Temple Place - Suite 330,
+    Boston, MA 02111-1307, USA.
 
 On Debian GNU/Linux systems, the complete text of the GNU General
 Public License can be found in `/usr/share/common-licenses/GPL'.
index 18c9524553beffc2bc33ee6a324ef0d82e1629bd..604f85209318b04332515c3b270e8120f9ac38f0 100644 (file)
@@ -1,2 +1,2 @@
-?package(netris):needs=text section=Games/Tetris-like title="Netris" \
+?package(netris):needs="text" section="Games/Tetris-like" title="Netris" \
   command="/usr/games/netris" longtitle="Networked Tetris"
diff --git a/game.c b/game.c
index 0c98b74f8437aab6a5991c7e5ccba51c7226d9f4..ad188cf0d28e38586876ad7259a6bf626809ba57 100644 (file)
--- a/game.c
+++ b/game.c
@@ -435,7 +435,8 @@ ExtFunc int main(int argc, char **argv)
                if (robotEnable)
                        InitRobot(robotProg);
                InitNet();
-               SRandom(time(0));
+               if (!initSeed)
+                       SRandom(time(0));
                if (initConn || waitConn) {
                        game = GT_classicTwo;
                        if(gameState != STATE_STARTING) {