]> git.deb.at Git - pkg/netris.git/blobdiff - debian/rules
Imported Debian patch 0.52-7
[pkg/netris.git] / debian / rules
index 3267cbb325f52ca981fed58b37bdf40b4c030083..38168531204b4e0aea0cea353962e0288013e7a5 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 # rules file for netris
+# copyright 2002++ by Gerfried Fuchs <rhonda@debian.at>
+# Licenced the same way as netris itself
 
 COPT = -g
 INSTALL = install
@@ -18,17 +20,19 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
 endif
 
 
-clean:
+include /usr/share/quilt/quilt.make
+
+clean: unpatch
        $(checkdir)
        $(checkroot)
        -rm -rf debian/netris debian/substvars debian/files \
                build-stamp install-stamp config.h .depend
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
        -rm -rf Makefile
 
 
 build: build-stamp
-build-stamp:
+build-stamp: patch
        $(checkdir)
        ./Configure -g
        $(MAKE) COPT="$(COPT)"