]> git.deb.at Git - pkg/blosxom.git/blobdiff - debian/rules
Convert debian/rules to dh style
[pkg/blosxom.git] / debian / rules
index 5601ec31f683bce19e84cdf0d56c16f0da69822e..014af8504fa9c4cd6fd69154282e982442a75c00 100755 (executable)
@@ -1,93 +1,10 @@
 #!/usr/bin/make -f
-# debian/rules for the blosxom package
-# copyright 2007-2008 by Rhonda D'Vine <rhonda@debian.org>
-# Licenced in the same way as blosxom itself
+#DH_VERBOSE = 1
 
-PKG = blosxom
-TMP = $(CURDIR)/debian/$(PKG)
-
-INSTALL = install
-INSTALL_FILE    = $(INSTALL) -p    -oroot -groot -m644
-INSTALL_PROGRAM = $(INSTALL) -p    -oroot -groot -m755
-INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
-INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
-
-
-
-clean:
-       $(checkdir)
-       $(checkroot)
-       -rm -rf $(TMP) debian/files
-
-
-build:
-       # uhm, build for a binary-indep package?  Don't try to be funny ;)
-
-
-install:
-       $(checkdir)
-       $(checkroot)
-       -rm -rf $(TMP)
-
-       $(INSTALL_DIR) $(TMP)
-       cd $(TMP) && $(INSTALL_DIR) usr/lib/cgi-bin \
-               var/lib/blosxom/data/flavours \
-               etc/blosxom/plugins etc/blosxom/plugins-available \
-               var/lib/blosxom/state var/lib/blosxom/static \
-               usr/share/doc/$(PKG) usr/share/man/man7
-
-       $(INSTALL_SCRIPT) blosxom.cgi       $(TMP)/usr/lib/cgi-bin/$(PKG)
-       $(INSTALL_FILE) debian/blosxom.conf $(TMP)/etc/blosxom
-       $(INSTALL_FILE) debian/blosxom.7    $(TMP)/usr/share/man/man7
-       $(INSTALL_FILE) debian/README       $(TMP)/usr/share/doc/$(PKG)
-       $(INSTALL_FILE) ChangeLog           $(TMP)/usr/share/doc/$(PKG)/changelog
-
-       $(INSTALL_FILE) debian/plugins/*    $(TMP)/etc/blosxom/plugins
-       $(INSTALL_FILE) debian/plugins-available/* \
-               $(TMP)/etc/blosxom/plugins-available
-
-       cd $(TMP)/usr/share && gzip -9n doc/$(PKG)/changelog \
-               man/man7/blosxom.7
+%:
+       dh $@
 
+override_dh_install:
+       dh_install
        chown www-data:www-data $(TMP)/var/lib/blosxom/state
        chown www-data:www-data $(TMP)/var/lib/blosxom/static
-
-
-binary-indep: install
-       $(checkdir)
-       $(checkroot)
-
-       $(INSTALL_DIR) $(TMP)/DEBIAN
-
-       $(INSTALL_FILE) debian/copyright debian/README.Debian \
-               debian/NEWS.Debian $(TMP)/usr/share/doc/$(PKG)
-       $(INSTALL_FILE) debian/changelog \
-               $(TMP)/usr/share/doc/$(PKG)/changelog.Debian
-       cd $(TMP)/usr/share/doc/$(PKG) && gzip -9n changelog.Debian NEWS.Debian
-
-       $(INSTALL_SCRIPT) debian/preinst debian/postrm $(TMP)/DEBIAN
-
-       find $(TMP)/etc -type f | sed -e 's#$(TMP)##' > $(TMP)/DEBIAN/conffiles
-
-       dpkg-gencontrol -ldebian/changelog -isp -p$(PKG) -P$(TMP)
-       cd $(TMP) && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
-               xargs -r0 md5sum > DEBIAN/md5sums
-       dpkg --build $(TMP) ..
-
-
-binary-arch:
-       # We have nothing to do here.
-
-
-binary: binary-indep binary-arch
-
-
-define checkdir
-       test -f debian/rules
-endef
-
-define checkroot
-       test root = "`whoami`"
-endef
-
-.PHONY: clean build install binary binary-arch binary-indep