]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Add recommended targets build-arch/build-indep to debian/rules
[pkg/t-prot.git] / debian / rules
index f8869418b694b5aa1c7ba1e5828a4eb18e5d9716..f55ee4ace36389d4cc5aee320f25df0c5967c245 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for t-prot package
-# Copyright 2002-2009 by Gerfried Fuchs <rhonda@debian.at>
-# Licenced BSD style
+# Copyright 2002-2012 by Gerfried Fuchs <rhonda@debian.org>
+# Licenced under WTFPLv2
 
 PKG = t-prot
 TMP = $(CURDIR)/debian/$(PKG)
@@ -13,21 +13,21 @@ INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
 INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
 
 
-include /usr/share/quilt/quilt.make
-
-clean: unpatch
+clean:
        $(checkdir)
        $(checkroot)
-       -rm -rf $(TMP) debian/files build-stamp
-
+       -rm -rf $(TMP) debian/files debian/stamp-*
 
-build-stamp: build
-build: patch
+build: build-arch build-indep
+build-arch: debian/stamp-build
+build-indep: debian/stamp-build
+debian/stamp-build:
        # uhm, build for a binary-indep package?  Don't try to be funny ;)
-       touch build-stamp
+       touch debian/stamp-build
 
 
-install: build
+install: debian/stamp-install
+debian/stamp-install: build
        $(checkdir)
        $(checkroot)
        -rm -rf $(TMP)
@@ -50,7 +50,7 @@ install: build
 
        $(INSTALL_FILE) TODO README $(TMP)/usr/share/doc/$(PKG)
        #$(INSTALL_FILE) contrib/README.patches contrib/t-prot-r*-gol.diff \
-       #       contrib/t-prot-r*-indentms.diff \
+       #       \
        #       $(TMP)/usr/share/doc/$(PKG)/contrib
        $(INSTALL_FILE) contrib/filter_innd.pl contrib/README.examples \
                $(TMP)/usr/share/doc/$(PKG)/examples
@@ -60,16 +60,16 @@ install: build
                man/man1/t-prot.1
 
 
-binary-indep: build install
+binary-indep: install
        $(checkdir)
        $(checkroot)
        $(INSTALL_DIR) $(TMP)/DEBIAN
        $(INSTALL_FILE) debian/copyright debian/README.Debian \
-               debian/NEWS.Debian $(TMP)/usr/share/doc/$(PKG)
+               $(TMP)/usr/share/doc/$(PKG)
        $(INSTALL_FILE) debian/changelog \
                $(TMP)/usr/share/doc/$(PKG)/changelog.Debian
        cd $(TMP)/usr/share/doc/$(PKG) && gzip -9 \
-               changelog.Debian NEWS.Debian
+               changelog.Debian
        $(INSTALL_SCRIPT) debian/postinst debian/postrm debian/config \
                $(TMP)/DEBIAN
        po2debconf debian/templates > $(TMP)/DEBIAN/templates
@@ -81,11 +81,11 @@ binary-indep: build install
        dpkg --build $(TMP) ..
 
 
-binary-arch: build install
+binary-arch:
        # We have nothing to do here.
 
 
-binary: binary-indep binary-arch
+binary: binary-indep
 
 
 define checkdir