]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
update my name
[pkg/t-prot.git] / debian / rules
index 947d2a1c7b50c66a6749a061e5ab2db070d72fd1..ed79cf847f29bd62dacabf159234278bd26d7282 100755 (executable)
@@ -1,10 +1,11 @@
 #!/usr/bin/make -f
 # debian/rules for t-prot package
-# Copyright 2002-2009 by Gerfried Fuchs <rhonda@debian.at>
+# Copyright 2002-2012 by Rhonda D'Vine <rhonda@debian.org>
 # Licenced under WTFPLv2
 
 PKG = t-prot
 TMP = $(CURDIR)/debian/$(PKG)
+BUILD_DATE = $(shell dpkg-parsechangelog --show-field Date)
 
 INSTALL = install
 INSTALL_FILE    = $(INSTALL) -p    -oroot -groot -m644
@@ -16,16 +17,20 @@ INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
 clean:
        $(checkdir)
        $(checkroot)
-       -rm -rf $(TMP) debian/files build-stamp
+       -rm -rf $(TMP) debian/files debian/stamp-*
+       $(MAKE) -f /usr/share/quilt/quilt.make unpatch
 
+build: build-arch build-indep
+build-arch: debian/stamp-build
+build-indep: debian/stamp-build
+debian/stamp-build:
+       # only thing to do is apply the patches ...
+       $(MAKE) -f /usr/share/quilt/quilt.make patch
+       touch debian/stamp-build
 
-build-stamp: build
-build:
-       # uhm, build for a binary-indep package?  Don't try to be funny ;)
-       touch build-stamp
 
-
-install: build
+install: debian/stamp-install
+debian/stamp-install: build
        $(checkdir)
        $(checkroot)
        -rm -rf $(TMP)
@@ -35,30 +40,21 @@ install: build
                usr/share/doc/$(PKG)/examples
        #       usr/share/doc/$(PKG)/contrib
        $(INSTALL_SCRIPT) t-prot   $(TMP)/usr/bin
-       patch $(TMP)/usr/bin/t-prot \
-               contrib/t-prot-r*-mutt15*.diff
-       -rm -f $(TMP)/usr/bin/t-prot.orig
        $(INSTALL_FILE)   t-prot.1 $(TMP)/usr/share/man/man1
        $(INSTALL_FILE) debian/Muttrc     $(TMP)/etc/t-prot
        $(INSTALL_FILE) debian/footers/*  $(TMP)/etc/t-prot/footers
        $(INSTALL_FILE) contrib/t-prot.sl $(TMP)/usr/share/slrn/macros
-       patch $(TMP)/usr/share/slrn/macros/t-prot.sl \
-               contrib/t-prot.sl-slang2.diff
-       -rm -f $(TMP)/usr/share/slrn/macros/t-prot.sl.orig
 
        $(INSTALL_FILE) TODO README $(TMP)/usr/share/doc/$(PKG)
-       #$(INSTALL_FILE) contrib/README.patches contrib/t-prot-r*-gol.diff \
-       #       \
-       #       $(TMP)/usr/share/doc/$(PKG)/contrib
        $(INSTALL_FILE) contrib/filter_innd.pl contrib/README.examples \
                $(TMP)/usr/share/doc/$(PKG)/examples
        $(INSTALL_FILE) ChangeLog \
                $(TMP)/usr/share/doc/$(PKG)/changelog
-       cd $(TMP)/usr/share && gzip -9 doc/$(PKG)/changelog \
+       cd $(TMP)/usr/share && gzip -n9 doc/$(PKG)/changelog \
                man/man1/t-prot.1
 
 
-binary-indep: build install
+binary-indep: install
        $(checkdir)
        $(checkroot)
        $(INSTALL_DIR) $(TMP)/DEBIAN
@@ -66,7 +62,7 @@ binary-indep: build install
                $(TMP)/usr/share/doc/$(PKG)
        $(INSTALL_FILE) debian/changelog \
                $(TMP)/usr/share/doc/$(PKG)/changelog.Debian
-       cd $(TMP)/usr/share/doc/$(PKG) && gzip -9 \
+       cd $(TMP)/usr/share/doc/$(PKG) && gzip -n9 \
                changelog.Debian
        $(INSTALL_SCRIPT) debian/postinst debian/postrm debian/config \
                $(TMP)/DEBIAN
@@ -76,6 +72,12 @@ binary-indep: build install
        dpkg-gencontrol -ldebian/changelog -isp -p$(PKG) -P$(TMP)
        cd $(TMP) && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
                xargs -r0 md5sum > DEBIAN/md5sums
+       # Make build reproducible:
+       # Hardcode permissions for files created by output redirection
+       chmod 644 $(TMP)/DEBIAN/md5sums $(TMP)/DEBIAN/templates
+       # Set timestamp of all files to timestamp in debian/changelog entry
+       find $(TMP) -depth -newermt '$(BUILD_DATE)' -print0 | \
+               xargs -0r touch --no-dereference --date='$(BUILD_DATE)'
        dpkg --build $(TMP) ..