]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Merge branch 'upstream'
[pkg/t-prot.git] / debian / rules
index f8869418b694b5aa1c7ba1e5828a4eb18e5d9716..63edcc94c7e1bb667bcfff5ca74a86409d1451ad 100755 (executable)
@@ -13,16 +13,14 @@ INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
 INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
 
 
-include /usr/share/quilt/quilt.make
-
-clean: unpatch
+clean:
        $(checkdir)
        $(checkroot)
        -rm -rf $(TMP) debian/files build-stamp
 
 
 build-stamp: build
-build: patch
+build:
        # uhm, build for a binary-indep package?  Don't try to be funny ;)
        touch build-stamp
 
@@ -50,7 +48,7 @@ install: build
 
        $(INSTALL_FILE) TODO README $(TMP)/usr/share/doc/$(PKG)
        #$(INSTALL_FILE) contrib/README.patches contrib/t-prot-r*-gol.diff \
-       #       contrib/t-prot-r*-indentms.diff \
+       #       \
        #       $(TMP)/usr/share/doc/$(PKG)/contrib
        $(INSTALL_FILE) contrib/filter_innd.pl contrib/README.examples \
                $(TMP)/usr/share/doc/$(PKG)/examples
@@ -65,11 +63,11 @@ binary-indep: build install
        $(checkroot)
        $(INSTALL_DIR) $(TMP)/DEBIAN
        $(INSTALL_FILE) debian/copyright debian/README.Debian \
-               debian/NEWS.Debian $(TMP)/usr/share/doc/$(PKG)
+               $(TMP)/usr/share/doc/$(PKG)
        $(INSTALL_FILE) debian/changelog \
                $(TMP)/usr/share/doc/$(PKG)/changelog.Debian
        cd $(TMP)/usr/share/doc/$(PKG) && gzip -9 \
-               changelog.Debian NEWS.Debian
+               changelog.Debian
        $(INSTALL_SCRIPT) debian/postinst debian/postrm debian/config \
                $(TMP)/DEBIAN
        po2debconf debian/templates > $(TMP)/DEBIAN/templates
@@ -81,11 +79,11 @@ binary-indep: build install
        dpkg --build $(TMP) ..
 
 
-binary-arch: build install
+binary-arch:
        # We have nothing to do here.
 
 
-binary: binary-indep binary-arch
+binary: binary-indep
 
 
 define checkdir