]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
debian/rules: Set timestamp of all files to the same time
[pkg/t-prot.git] / debian / rules
index f55ee4ace36389d4cc5aee320f25df0c5967c245..3104ee7cbf347106377ae6d7f445ed75433c6d83 100755 (executable)
@@ -5,6 +5,7 @@
 
 PKG = t-prot
 TMP = $(CURDIR)/debian/$(PKG)
+BUILD_DATE = $(shell dpkg-parsechangelog --show-field Date)
 
 INSTALL = install
 INSTALL_FILE    = $(INSTALL) -p    -oroot -groot -m644
@@ -17,12 +18,14 @@ clean:
        $(checkdir)
        $(checkroot)
        -rm -rf $(TMP) debian/files debian/stamp-*
+       $(MAKE) -f /usr/share/quilt/quilt.make unpatch
 
 build: build-arch build-indep
 build-arch: debian/stamp-build
 build-indep: debian/stamp-build
 debian/stamp-build:
-       # uhm, build for a binary-indep package?  Don't try to be funny ;)
+       # only thing to do is apply the patches ...
+       $(MAKE) -f /usr/share/quilt/quilt.make patch
        touch debian/stamp-build
 
 
@@ -37,26 +40,17 @@ debian/stamp-install: build
                usr/share/doc/$(PKG)/examples
        #       usr/share/doc/$(PKG)/contrib
        $(INSTALL_SCRIPT) t-prot   $(TMP)/usr/bin
-       patch $(TMP)/usr/bin/t-prot \
-               contrib/t-prot-r*-mutt15*.diff
-       -rm -f $(TMP)/usr/bin/t-prot.orig
        $(INSTALL_FILE)   t-prot.1 $(TMP)/usr/share/man/man1
        $(INSTALL_FILE) debian/Muttrc     $(TMP)/etc/t-prot
        $(INSTALL_FILE) debian/footers/*  $(TMP)/etc/t-prot/footers
        $(INSTALL_FILE) contrib/t-prot.sl $(TMP)/usr/share/slrn/macros
-       patch $(TMP)/usr/share/slrn/macros/t-prot.sl \
-               contrib/t-prot.sl-slang2.diff
-       -rm -f $(TMP)/usr/share/slrn/macros/t-prot.sl.orig
 
        $(INSTALL_FILE) TODO README $(TMP)/usr/share/doc/$(PKG)
-       #$(INSTALL_FILE) contrib/README.patches contrib/t-prot-r*-gol.diff \
-       #       \
-       #       $(TMP)/usr/share/doc/$(PKG)/contrib
        $(INSTALL_FILE) contrib/filter_innd.pl contrib/README.examples \
                $(TMP)/usr/share/doc/$(PKG)/examples
        $(INSTALL_FILE) ChangeLog \
                $(TMP)/usr/share/doc/$(PKG)/changelog
-       cd $(TMP)/usr/share && gzip -9 doc/$(PKG)/changelog \
+       cd $(TMP)/usr/share && gzip -n9 doc/$(PKG)/changelog \
                man/man1/t-prot.1
 
 
@@ -68,7 +62,7 @@ binary-indep: install
                $(TMP)/usr/share/doc/$(PKG)
        $(INSTALL_FILE) debian/changelog \
                $(TMP)/usr/share/doc/$(PKG)/changelog.Debian
-       cd $(TMP)/usr/share/doc/$(PKG) && gzip -9 \
+       cd $(TMP)/usr/share/doc/$(PKG) && gzip -n9 \
                changelog.Debian
        $(INSTALL_SCRIPT) debian/postinst debian/postrm debian/config \
                $(TMP)/DEBIAN
@@ -78,6 +72,8 @@ binary-indep: install
        dpkg-gencontrol -ldebian/changelog -isp -p$(PKG) -P$(TMP)
        cd $(TMP) && find * -type f ! -regex '^DEBIAN/.*' -print0 | \
                xargs -r0 md5sum > DEBIAN/md5sums
+       find $(TMP) -depth -newermt '$(BUILD_DATE)' -print0 | \
+               xargs -0r touch --no-dereference --date='$(BUILD_DATE)'
        dpkg --build $(TMP) ..