]> git.deb.at Git - pkg/abook.git/blobdiff - debian/rules
Imported Debian patch 0.5.6-6
[pkg/abook.git] / debian / rules
index 21ac1efde4ae04606e3de84a33783d3516994a06..ab966e2f12f4ca788f934beb6d9cf160ab3f1e00 100755 (executable)
@@ -1,5 +1,8 @@
 #!/usr/bin/make -f
 # debian/rules for abook
+# copyright 2003-2008 by Gerfried Fuchs <rhonda@debian.at>
+# Licenced the same way as abook itself
+
 PKG = abook
 TMP = $(CURDIR)/debian/$(PKG)
 
@@ -19,6 +22,7 @@ else
 endif
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
+       STRIP = true
 endif
 
 
@@ -50,6 +54,9 @@ install: build
        cd $(TMP) && $(INSTALL_DIR) usr/share/doc/$(PKG)/examples \
                usr/share/doc/$(PKG)/contrib
        $(MAKE) prefix=$(TMP)/usr install INSTALL_PROGRAM="$(INSTALL_PROGRAM)"
+       test "$(STRIP)" != true || strip \
+               --remove-section=.comment --remove-section=.note \
+               $(TMP)/usr/bin/abook
        $(INSTALL_FILE) ChangeLog $(TMP)/usr/share/doc/$(PKG)/changelog
        $(INSTALL_FILE) ANNOUNCE AUTHORS BUGS FAQ README THANKS TODO \
                $(TMP)/usr/share/doc/$(PKG)