]> git.deb.at Git - pkg/t-prot.git/blobdiff - debian/rules
Imported Debian patch 2.5-2
[pkg/t-prot.git] / debian / rules
index e43c585786cd1185a5fa3865c4cf3b03d1ef2284..4ef43b5f02e13ef897139345f6f919ef439cd9c1 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for t-prot package
+# (c) 2002-2008 by Gerfried Fuchs <rhonda@debian.at>
+# Licenced in the same way as t-prot itself
 
 PKG = t-prot
 TMP = $(CURDIR)/debian/$(PKG)
@@ -11,14 +13,18 @@ INSTALL_SCRIPT  = $(INSTALL) -p    -oroot -groot -m755
 INSTALL_DIR     = $(INSTALL) -p -d -oroot -groot -m755
 
 
-clean:
+include /usr/share/quilt/quilt.make
+
+clean: unpatch
        $(checkdir)
        $(checkroot)
-       -rm -rf $(TMP) debian/files
+       -rm -rf $(TMP) debian/files build-stamp
 
 
-build:
+build-stamp: build
+build: patch
        # uhm, build for a binary-indep package?  Don't try to be funny ;)
+       touch build-stamp
 
 
 install: build
@@ -32,7 +38,7 @@ install: build
        #       usr/share/doc/$(PKG)/contrib
        $(INSTALL_SCRIPT) t-prot   $(TMP)/usr/bin
        patch $(TMP)/usr/bin/t-prot \
-               contrib/t-prot-r*-mutt157.diff
+               contrib/t-prot-r*-mutt15*.diff
        -rm -f $(TMP)/usr/bin/t-prot.orig
        $(INSTALL_FILE)   t-prot.1 $(TMP)/usr/share/man/man1
        $(INSTALL_FILE) debian/Muttrc     $(TMP)/etc/t-prot